Impending Database Upgrade
Incident Report for Flying Sphinx
Resolved
Everything's been running with no issues for a good while. Database upgrade is considered a success. Thanks everyone for your patience and understanding!
Posted over 1 year ago. May 21, 2016 - 21:52 AEST
Monitoring
The database upgrade has been completed (a little ahead of schedule!). Everything is now up and running again, but I'll continue to keep an eye on things just to be sure.
Posted over 1 year ago. May 21, 2016 - 17:45 AEST
Update
The change is now underway.
Posted over 1 year ago. May 21, 2016 - 15:00 AEST
Update
Just a reminder that this database upgrade will be taking place in 30 minutes.
Posted over 1 year ago. May 21, 2016 - 14:30 AEST
Identified
On Saturday the 21st of May at 5:00am UTC, the database for the central Flying Sphinx API will be upgraded. This process is expected to take around four hours, and during this time, no API commands will be functioning (i.e. anything via the flying-sphinx CLI tool or rake tasks). Customers will be unable to add/remove the add-on from their apps. However, Sphinx daemons (and thus, search functionality) will continue to function unhindered.

The length of time is certainly far from ideal, but unfortunately it's a required upgrade from the database provider. Due to the amount of data involved, this is about as fast as it can possibly be.

Expected time of impact in different timezones:

* US West Coast (PDT): 10pm Friday 20th to 2am Saturday 21st May.
* US East Coast (EDT): 1am to 5am Saturday 21st May.
* Central Europe (CEST): 7am to 11am Saturday 21st May.
* Australian East Coast (AEST): 3pm to 7pm Saturday 21st May.

If you have any questions or concerns about this, please do get in touch.
Posted over 1 year ago. May 18, 2016 - 18:08 AEST