API is struggling.
Incident Report for Flying Sphinx
Resolved
Considering this issue resolved. Redis is purring along, API calls are being processed. If you've spotted any issues that are still occurring, do get in touch.
Posted over 2 years ago. Apr 26, 2015 - 14:09 AEST
Monitoring
Okay, switched Redis providers, we're back to normal. Greatly apologise for the delay (and have raised a ticket with Pingdom to follow up on why their alerts are not currently coming through to my 24/7 phone, which would have led to this being resolved sooner).
Posted over 2 years ago. Apr 26, 2015 - 13:50 AEST
Identified
Just a quick addition: Searching is unaffected by this, but any Sphinx commands (stop, start, index) are not being processed. I've contacted the Redis provider, looking for a fast resolution there, but if there's no movement soon, will look into new infrastructure.
Posted over 2 years ago. Apr 26, 2015 - 11:48 AEST
Investigating
Looking into the cause, seems to be related to the Redis provider.
Posted over 2 years ago. Apr 26, 2015 - 11:34 AEST